Author Topic: FBA 0.2.97.40 working rom .dat  (Read 1180 times)

Offline Bankai

  • Newbies
  • *
  • Posts: 5
  • Karma: +0/-0
FBA 0.2.97.40 working rom .dat
« on: June 06, 2017, 03:43:13 pm »
Hi all, I have a full FBA 0.2.97.40 romset (split). Great! But.. I'm getting really lost in it  :eek:

Is there a Clrmamepro .dat file with ONLY the working roms?

I've tried compiling it myself through CMP, but I just can't figure it out..

Would be great!

Offline JacKc

  • FBA Dev
  • ******
  • Posts: 1562
  • Karma: +51/-0
  • Sarah Connor !?
Re: FBA 0.2.97.40 working rom .dat
« Reply #1 on: June 06, 2017, 04:32:15 pm »
There is no FB Alpha 0.2.97.40 dat for clrmamepro with only working games...Only a few games are not working in FB Alpha.

In general we don't add non working games except sometimes when a working bootleg clone and/or an unprotected set needs a non working parent (not working due to unemulated protection, etc...).


Offline Bankai

  • Newbies
  • *
  • Posts: 5
  • Karma: +0/-0
Re: FBA 0.2.97.40 working rom .dat
« Reply #2 on: June 06, 2017, 06:22:47 pm »
Thanks for replying.

Is the retroarch FBA core less compatible with arcade roms than the "vanilla" FBA emulator? Because when I try loading up a game like Donpachi, retroarch FBA core doesn't work

Offline Stifu

  • Jr. Member
  • **
  • Posts: 50
  • Karma: +0/-0
Re: FBA 0.2.97.40 working rom .dat
« Reply #3 on: June 07, 2017, 03:05:46 pm »
Is the retroarch FBA core less compatible with arcade roms than the "vanilla" FBA emulator?
Slightly, but it gets better with each release (like, not long ago, most Irem games didn't work in the retroarch version).

Because when I try loading up a game like Donpachi, retroarch FBA core doesn't work
I can't check now but I'm pretty sure I had it working with 0.2.97.39.

Offline el_rika

  • Newbies
  • *
  • Posts: 37
  • Karma: +0/-0
Re: FBA 0.2.97.40 working rom .dat
« Reply #4 on: June 08, 2017, 05:42:57 pm »
I play all Cave games (DonPachi, DonDonPachi, Esprade, etc) in .40 FBA core in Retroarch daily.

It definitely must be your romset, which could be incompatible with the FBA core.

edit: just checked and DonPachi works in .30 FBA core, .38, .39 as well.
« Last Edit: June 08, 2017, 05:44:40 pm by el_rika »

Offline barbudreadmon

  • Expert
  • *****
  • Posts: 275
  • Karma: +7/-0
  • lr-fbalpha developer
Re: FBA 0.2.97.40 working rom .dat
« Reply #5 on: June 10, 2017, 11:06:50 am »
like, not long ago, most Irem games didn't work in the retroarch version.
Not exactly true, that was an arm specific issue, i think upstream is still affected by this bug ("#define INT8 char" still in nec.cpp ?), except upstream don't have an arm release.

Offline Bankai

  • Newbies
  • *
  • Posts: 5
  • Karma: +0/-0
Re: FBA 0.2.97.40 working rom .dat
« Reply #6 on: June 11, 2017, 02:27:44 am »
Thanks for the replies guys! It was my romset indeed.

I now have all CPS (1,2 and 3) games bundled in my frontend, next a NeoGeo category, next to a MAME "everything but CPS and NeoGeo" category. Good stuff! :)