Author Topic: Help to check version of FBNeo  (Read 2225 times)

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Help to check version of FBNeo
« on: December 29, 2020, 08:49:11 AM »
Hi and happy holidays!

Please pardon for the basic questions.

Actually I'm enjoying FB Neo on a Retroarch-based distro, RGB-Pi OS.
The libretro core (lr-fbneo) is version 0.2.97.44 3b.

I've reported in Github a graphical glitch in Violent Storm, and I was told that FB Neo does not suffer of that glitch anymore, so I suppose that my libretro core is not up-to-date.

So where may I check the latest release of FB Neo? And there is a way to download a more recent lr-core for Raspberry Pi 3?

Thank you!

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 854
  • Karma: +36/-1
  • Helper
Re: Help to check version of FBNeo
« Reply #1 on: December 29, 2020, 11:47:26 AM »
I don't know, and from what i understand this RGB-Pi stuff is illegal since it provides our non-commercial emulator in a paid bundle, so don't expect help from us.

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #2 on: December 29, 2020, 03:41:16 PM »
Hello,
AFAIK RGB-Pi OS is free to download, I was never asked to pay anything (it is just another Retroarch distro like many others).

And I was just asking a way to check if lr-fbneo is up-to-date to main release...

If i was rude (?) i apologize, but honestly i don't think i did anything wrong.
 

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 854
  • Karma: +36/-1
  • Helper
Re: Help to check version of FBNeo
« Reply #3 on: December 29, 2020, 06:06:36 PM »
Weird, when i searched RGB-Pi OS over google, i didn't find any download link, only some company selling that RGB-Pi jamma based solution with that OS pre-installed. Anyway i don't know anything about that OS, you'll have to read their documentation.

The libretro core (lr-fbneo) is version 0.2.97.44 3b.

Current version is 1.0.0.01

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #4 on: December 29, 2020, 06:49:16 PM »
RGB-Pi sells SCART and JAMMA adapters for Raspberry Pi, but their OS can be downloaded for free from the homepage (https://www.rgb-pi.com/) under the Downloads section, and it can be also used with other cables too (the download button seems a banner, not a happy design...).

But it seems that the "official" libretro core of FB Neo for ARM devices is still not updated to the latest release (so, this is a generic problem of the libretro core on ARM... or maybe it is only a matter of time).

Thank you


Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 854
  • Karma: +36/-1
  • Helper
Re: Help to check version of FBNeo
« Reply #5 on: December 30, 2020, 03:55:58 AM »
Yeah, it seems like i was misled by the design, and too focused on the "buy" button and the lack of documentation on how to install the OS.

So they are using the generic arm builds from libretro "core updater" ? Well, considering how big the impact of optimized cflags is on those platforms (i think we are in the range of 20-30% performance gain here), they should give optimized packages and a tool to update them from sources like retropie and pretty much any of those retrogaming distros.
Not sure when or if that libretro generic arm buildbot will be back, its disappearance might be permanent tbh since those platforms usually make their own optimized builds.
« Last Edit: December 30, 2020, 07:02:28 AM by barbudreadmon »

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 854
  • Karma: +36/-1
  • Helper
Re: Help to check version of FBNeo
« Reply #6 on: December 30, 2020, 07:01:15 AM »
I asked around, it seems there are plans to bring that buildbot back, it might be in a few months though, they have been in the process of migrating their buildbot architecture over the last months and this one is a low priority.

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #7 on: December 30, 2020, 07:40:46 AM »
Yeah, it seems like i was misled by the design, and too focused on the "buy" button and the lack of documentation on how to install the OS.

So they are using the generic arm builds from libretro "core updater" ? Well, considering how big the impact of optimized cflags is on those platforms (i think we are in the range of 20-30% performance gain here), they should give optimized packages and a tool to update them from sources like retropie and pretty much any of those retrogaming distros.
Not sure when or if that libretro generic arm buildbot will be back, its disappearance might be permanent tbh since those platforms usually make their own optimized builds.

I'm not an expert, but there are two nightly ARM builds: armhf and armv7-neon-hf. I suppose the latter is optimized for Raspberry Pi 3?
Both are dated 18/11, honestly I don't understand what's happening and I'm a bit confused (when version 1.0.0.01 came out?)

May I build one updated version of the Libretro core of FBNeo by myself?  :S

Thank you
 

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 854
  • Karma: +36/-1
  • Helper
Re: Help to check version of FBNeo
« Reply #8 on: December 30, 2020, 09:24:30 AM »
I suppose the latter is optimized for Raspberry Pi 3?

It's for generic neon platforms, meaning dozens of different cpus that will benefit a lot from more precise cflags.

May I build one updated version of the Libretro core of FBNeo by myself?  :S

You might be able to build a core by cloning https://github.com/libretro/FBNeo.git then using this make command :
make -j5 -C src/burner/libretro/ platform=rpi3

You'll need dev tools on your pi though, and to copy the core to the right place, i can't give you guidance about that.

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #9 on: December 30, 2020, 11:03:48 AM »
I was able to build the core and to put it in the right folder: and it is AWESOME!!!  :biggrin:
I can really see the difference in performance against the generic builds!

Thank you very much for your patience and your kind support!!!

Last question: is the "Enable Cyclone" option good for Rpi3? Thanks

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 854
  • Karma: +36/-1
  • Helper
Re: Help to check version of FBNeo
« Reply #10 on: December 30, 2020, 11:16:04 AM »
Last question: is the "Enable Cyclone" option good for Rpi3? Thanks

Not globally because it breaks lots of games (musashi is a far better m68k interpreter), but if you encounter a game using m68k (lots of games use that cpu) that won't run fullspeed on your pi3, it's worth giving it a try.

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #11 on: December 30, 2020, 11:23:26 AM »
Great! Thank you very much!

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #12 on: August 22, 2021, 06:20:07 AM »
It's for generic neon platforms, meaning dozens of different cpus that will benefit a lot from more precise cflags.

You might be able to build a core by cloning https://github.com/libretro/FBNeo.git then using this make command :
make -j5 -C src/burner/libretro/ platform=rpi3

You'll need dev tools on your pi though, and to copy the core to the right place, i can't give you guidance about that.

Hello,
I hope you are doing well!

I'd like to build the new release (v1.0.0.02) for Raspberry Pi 3. Do I need to compile it also on Rpi3 or may I use another platform? (Windows, my other RPi 4 etc.)? Thank you so much.

Offline dink

  • Administrator
  • *****
  • Posts: 4315
  • Karma: +374/-1
  • pie? I nearly bought one!
Re: Help to check version of FBNeo
« Reply #13 on: August 22, 2021, 09:19:19 AM »
Hi,
Just download the source from here: https://github.com/libretro/FBNeo
There's the green button, click it and select "download zip".  Unzip it and run the make command that barbudreadmon said a few messages up:
make -j5 -C src/burner/libretro/ platform=rpi3

The .2 version is kinda old, the method I said above will get you the latest development version (.3) which is up to date.

best regards,
- dink
« Last Edit: August 22, 2021, 11:09:46 AM by barbudreadmon »

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #14 on: August 23, 2021, 05:54:57 PM »
Thank you so much!  :biggrin: