Author Topic: FB Neo Bugs Reports  (Read 28043 times)

Offline ClessxAlghazanth

  • Newbies
  • *
  • Posts: 48
  • Karma: +1/-0
Re: FB Neo Bugs Reports
« Reply #540 on: April 28, 2021, 09:22:57 PM »
Battle Garegga has a strange crackling noise around the start of 2nd stage (regardless of the stage order) which lasts for a few seconds and then goes away

Using the parent rom
Battle Garegga (Europe / USA / Japan / Asia) (Sat Feb 3 1996)

Anyone experienced something similar ?

I have the latest github build

Best regards

« Last Edit: April 28, 2021, 09:27:34 PM by ClessxAlghazanth »

Offline matchew64

  • Newbies
  • *
  • Posts: 12
  • Karma: +0/-0
Re: FB Neo Bugs Reports
« Reply #541 on: April 28, 2021, 11:08:06 PM »
RetroArch, Win10

edf

flickering garbage at two places. One in the intro screen, the other half-way through stage 2

not present in mame 0.139

Obviously not a huge deal, but I notice these kinds of things.

Thanks, as always!

Offline dink

  • Administrator
  • *****
  • Posts: 4205
  • Karma: +360/-0
  • pie? I nearly bought one!
Re: FB Neo Bugs Reports
« Reply #542 on: April 29, 2021, 12:53:07 AM »
Battle Garegga has a strange crackling noise around the start of 2nd stage (regardless of the stage order) which lasts for a few seconds and then goes away

Using the parent rom
Battle Garegga (Europe / USA / Japan / Asia) (Sat Feb 3 1996)

Anyone experienced something similar ?

I have the latest github build

Best regards

I'm trying to reproduce the problem on my side, but I can't.  Of course, it needs to be reproduced in order to fix it.
Can you give me a savestate file from right before the crackling starts?

Does this problem happen if you turn the Low-pass Filter option off?   Or does it help if you increase the buffersize under "Audio -> Buffer size"?
Lastly, if you press backspace to show FPS, do you notice a drop in framerate as it crackles?

best regards,
- dink
« Last Edit: April 29, 2021, 01:13:43 AM by dink »

Offline dink

  • Administrator
  • *****
  • Posts: 4205
  • Karma: +360/-0
  • pie? I nearly bought one!
Re: FB Neo Bugs Reports
« Reply #543 on: April 29, 2021, 01:26:20 AM »
RetroArch, Win10

edf

flickering garbage at two places. One in the intro screen, the other half-way through stage 2

not present in mame 0.139

Obviously not a huge deal, but I notice these kinds of things.

Thanks, as always!

thanks matchew64, the problem has been fixed :)

best regards,
- dink

Offline ClessxAlghazanth

  • Newbies
  • *
  • Posts: 48
  • Karma: +1/-0
Re: FB Neo Bugs Reports
« Reply #544 on: April 30, 2021, 01:52:16 AM »
I have managed to reproduce the sound issue in Battle Garegga after having a few tries

This time happened at the start of the 1st stage

I used to have the low pass filter off last time the issue occured , this time i have it turned on

Save file attached for reference

Best regards

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 824
  • Karma: +35/-1
  • Helper
Re: FB Neo Bugs Reports
« Reply #545 on: April 30, 2021, 02:17:42 AM »
@ClessxAlghazanth : What about fps ? Considering your previous issues, i can't think of this as something unrelated to the poor performances of your computer.

Offline ClessxAlghazanth

  • Newbies
  • *
  • Posts: 48
  • Karma: +1/-0
Re: FB Neo Bugs Reports
« Reply #546 on: April 30, 2021, 02:32:27 AM »
@ClessxAlghazanth : What about fps ? Considering your previous issues, i can't think of this as something unrelated to the poor performances of your computer.

I checked again and the fps is around 59~60 fps and no frame rate drop happens while the issue happens

I'll fiddle a bit more with the sound options and see if there is any change

By the way what does 2-point and 4-point order sample interpolation do ?

And I wonder changing sound buffer (currently set to 6) may cause any difference ?

Best regards

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 824
  • Karma: +35/-1
  • Helper
Re: FB Neo Bugs Reports
« Reply #547 on: April 30, 2021, 02:43:07 AM »
I checked again and the fps is around 59~60 fps and no frame rate drop happens while the issue happens

Hmmm, the game is supposed to run at a solid 60fps. Do you have frameskip enabled ? How is the fps if you disable it ?

Offline ClessxAlghazanth

  • Newbies
  • *
  • Posts: 48
  • Karma: +1/-0
Re: FB Neo Bugs Reports
« Reply #548 on: April 30, 2021, 03:11:49 AM »
Hmmm, the game is supposed to run at a solid 60fps. Do you have frameskip enabled ? How is the fps if you disable it ?

I have normally it disabled

Tried with Auto frameskip 'On' and no noticeable difference , still 59~60 fps , going up and down constantly (no noticeable slowdown)

Another issue (bug?) maybe but not sure

Space Firebird (1980) autofire doesn't function (doesn't shoot at all)


Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 824
  • Karma: +35/-1
  • Helper
Re: FB Neo Bugs Reports
« Reply #549 on: April 30, 2021, 03:30:24 AM »
I have normally it disabled

I recommend leaving it enabled.
The thing with "crackling sound" issues is that almost all of them are caused by poor performances, and the few that aren't are usually reproducible consistently and will last for more than a few seconds.
I got perfectly normal sound here using your savestate.
Did you check your cpu usage in your task manager ?

Edit : spacefb, it seems something is preventing rapid fire, it even happens with "physical" auto-fire (my controller has an auto-fire setting), it might be that the game is deliberately refusing rapid fire ?
« Last Edit: April 30, 2021, 03:57:07 AM by barbudreadmon »

Offline ClessxAlghazanth

  • Newbies
  • *
  • Posts: 48
  • Karma: +1/-0
Re: FB Neo Bugs Reports
« Reply #550 on: April 30, 2021, 04:38:50 AM »
I recommend leaving it enabled.
The thing with "crackling sound" issues is that almost all of them are caused by poor performances, and the few that aren't are usually reproducible consistently and will last for more than a few seconds.
I got perfectly normal sound here using your savestate.
Did you check your cpu usage in your task manager ?

Edit : spacefb, it seems something is preventing rapid fire, it even happens with "physical" auto-fire (my controller has an auto-fire setting), it might be that the game is deliberately refusing rapid fire ?

Got it  :wink: Will keep auto-frameskip on and check the cpu usage (nothing game-breaking so no prob  :smilie:)

Probably something acting up with my laptop (which is far less than ideal for a gaming computer  :p)

Space Firebird , that is interesting

I wonder if any other games have that kind of behaviour (in terms of preventing cheating maybe?)

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 824
  • Karma: +35/-1
  • Helper
Re: FB Neo Bugs Reports
« Reply #551 on: April 30, 2021, 08:51:39 AM »
I wonder if any other games have that kind of behaviour (in terms of preventing cheating maybe?)

I don't think that would be something that fancy, it's just that programmers of old never even thought about autofire, and something in their program probably goes wrong when fire button is pressed too frequently. Did you know that many cabinets crash if you trigger opposite directions at the same time ?

Offline dink

  • Administrator
  • *****
  • Posts: 4205
  • Karma: +360/-0
  • pie? I nearly bought one!
Re: FB Neo Bugs Reports
« Reply #552 on: April 30, 2021, 09:24:23 AM »
My fps bounces between 59.96 and 60.8, that's ok, though it's trouble if it dips below 60 for several frames.
Try "Audio -> Select Plugin -> XAudio 2", sometimes this gets a bit better results on some systems.
Another 2 things to try:
"Misc -> Options -> Set application process priority -> Above Normal" (enable this)
And also "Misc -> Options -> Enable High resolution system timer" (try toggling this)

Lastly, I can recommend SysInternals Process Explorer https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer
Open the cpu graph, click the little cpu graph which is directly in the middle of the menu bar and watch it as you play a game, to see if there are any spikes in cpu usage when the crackles occur.

best regards,
- dink

Offline ClessxAlghazanth

  • Newbies
  • *
  • Posts: 48
  • Karma: +1/-0
Re: FB Neo Bugs Reports
« Reply #553 on: April 30, 2021, 09:31:17 PM »
My fps bounces between 59.96 and 60.8, that's ok, though it's trouble if it dips below 60 for several frames.
Try "Audio -> Select Plugin -> XAudio 2", sometimes this gets a bit better results on some systems.
Another 2 things to try:
"Misc -> Options -> Set application process priority -> Above Normal" (enable this)
And also "Misc -> Options -> Enable High resolution system timer" (try toggling this)

Lastly, I can recommend SysInternals Process Explorer https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer
Open the cpu graph, click the little cpu graph which is directly in the middle of the menu bar and watch it as you play a game, to see if there are any spikes in cpu usage when the crackles occur.


Thanks ! :cool: will try and report

Asteroids Deluxe black screen in-game

The main screen is displayed fine , but after starting to play , the screen is all black (the sound effects keep playing)

The thing is that , I can swear it ran fine last time I played it

I have only changed priority : above normal this morning  (changing it back to normal, changing blitter doesn't help)

I also tried deleting the config files of the game , didn't help :(

(savestate attached for reference)

Any ideas on this ?

Best regards
« Last Edit: April 30, 2021, 09:36:49 PM by ClessxAlghazanth »

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 824
  • Karma: +35/-1
  • Helper
Re: FB Neo Bugs Reports
« Reply #554 on: May 01, 2021, 02:15:54 AM »
@ClessxAlghazanth : it appears this one crashes from its hiscore support i added recently, so i disabled the hiscores in astdelux for now