Final Burn Neo > FBN Discussion

Possible FBN bug in XP

(1/2) > >>

I've been upgrading my old machines to the latest possible software, and on one XP machine I noticed FBN had been installed.

Upon trying to run it I got an error about unable to initialise DirectX, and to install a runtime. According to dxdiag it's running DirectX 9.0c with no issues. Nevertheless I downloaded and installed the runtime, but it made no difference.

I asked on discord and was advised to try another blitter. I found that out of the 5 blitters on offer, only the first 2 worked (Basic and Soft-something). The other 3 produce the error. I tried upgrading FBNeo to the latest github version, but the problem remains.

I'm not at the machine now, so that's why things are not as precisely worded as they could be.

My question is - should the other 3 blitters work? If so, what should I look for?

That's odd - Enhanced (d3d7) and the 2 dx9 blitters work fine on my XP system with 9.0c (including the first 2).
Did you perhaps install some sort of dx filter / translation or shader dx-passthrough at some point?  Are there any dlls in the directory of fbneo.exe?
What happens if you temporarily rename config/fbneo.ini, and have it start with new settings?

best regards,
- dink

I haven't intentionally installed shaders and so on, unless they came with some other software.

I'll check out the dlls and the fbneo.ini when i can get back to the machine. I'll also try installing fbneo on another XP machine (I have a lot of them) and then get back to you.

No dlls, and i deleted fbneo.ini, but nothing worked. Therefore I transferred and the 2 roms to another XP machine, and it all worked fine there. So the original machine must have something wrong with it, even though every other program has no issues.

One thing I noticed on the new machine, where it says Garou mark of the wolves, there's a few invalid characters between garou and mark. Can you have a look in the source about that?

Hmmm, I can't explain the dx issue, sorry :/

Regarding Garou, the 2 characters are unicode for Kanji, perhaps the machine doesn't have Kanji support?  Try checking "Latin text only", in the top-right of the game list screen.


[0] Message Index

[#] Next page

Go to full version