Author Topic: Help to check version of FBNeo  (Read 808 times)

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #15 on: August 23, 2021, 07:00:08 PM »
Uhm, it seems that SYSTEM16 has become too heavy/slow for Raspberry Pi 3,  and so it is the new SYSTEM32.
Maybe I'll stick to 1001.

Offline dink

  • Administrator
  • *****
  • Posts: 4285
  • Karma: +372/-0
  • pie? I nearly bought one!
Re: Help to check version of FBNeo
« Reply #16 on: August 23, 2021, 08:50:58 PM »
Uhm, it seems that SYSTEM16 has become too heavy/slow for Raspberry Pi 3,  and so it is the new SYSTEM32.
Maybe I'll stick to 1001.

What games did you try on System16?  When barbudreadmon gets back, we'll try to figure out what went wrong.

It might be worth a try to bump the optimization level - edit src/burner/libretro/Makefile and search for:
CFLAGS += -O2 -DNDEBUG
CXXFLAGS += -O2 -DNDEBUG
and change to:
CFLAGS += -O3 -DNDEBUG
CXXFLAGS += -O3 -DNDEBUG

best regards,
- dink

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #17 on: August 24, 2021, 12:30:30 AM »
Hello,
I've tried Michael Jackson's Moonwalker and even Altered Beast, and it seems to me that they are much slower now.
Meanwhile I'll check again on v.10001 just to be sure.
Thank you so much.

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 842
  • Karma: +36/-1
  • Helper
Re: Help to check version of FBNeo
« Reply #18 on: August 24, 2021, 05:40:41 AM »
Iirc that's system 18 and has been a tad too demanding for a pi3 since the video issues have been fixed a while back

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #19 on: August 24, 2021, 08:29:55 AM »
Correct, it's System18! :eek:
But IIRC (I have to test it again) speed was good in v1001, with v1002 sprites handling has changed and it is too much for the good old RPi3.
What about some kind of option/dipswitch for systems like RPi3? It's still very popular especially for CRT users.

Thanks

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 842
  • Karma: +36/-1
  • Helper
Re: Help to check version of FBNeo
« Reply #20 on: August 24, 2021, 08:33:57 AM »
Hmmm i would think that video code update is older than 1.0.0.01. Maybe you had frameskip enabled in core options back then ? The settings changed, so you might have to reconfigure it (auto seems broken btw)

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #21 on: August 24, 2021, 08:40:56 AM »
I'll check again and report here.  :wink:
BTW thanks always for your patience, your kind feedback and all the hard work.

Offline antiriad

  • Newbies
  • *
  • Posts: 20
  • Karma: +0/-0
Re: Help to check version of FBNeo
« Reply #22 on: September 12, 2021, 01:54:37 AM »
Hi,
there is a way, in Retroarch, to check if the lr-fbneo core has been compiled specifically for RPi4? I'm using the default Lakka (3.4) core and I'd like to check this.
Thanks!

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 842
  • Karma: +36/-1
  • Helper
Re: Help to check version of FBNeo
« Reply #23 on: September 12, 2021, 04:22:00 AM »
No idea, ask the lakka team