Author Topic: Opening FBNeo taking longer than 1 min  (Read 116 times)

Offline kousoku

  • New Member
  • *
  • Posts: 4
  • Karma: +0/-0
Opening FBNeo taking longer than 1 min
« on: January 05, 2021, 07:53:02 PM »
Hello,

I am having an issue where opening FBNeo is taking longer than 1 min. About 1 min 20 sec on average. I have a pretty good computer (specs below) and am not sure how to troubleshoot the issue.

-----------------
System Information
------------------
     
Operating System: Windows 10 Home 64-bit
Language: English (Regional Setting: English)
System Manufacturer: Gigabyte Technology Co., Ltd.
System Model: Z390 I AORUS PRO WIFI
Processor: Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz (16 CPUs), ~3.6GHz
Memory: 16384MB RAM
Available OS Memory: 16316MB RAM
DirectX Version: DirectX 12
DX Setup Parameters: Not found
DirectX Database Version: Unknown
DxDiag Version: 10.00.18362.0387 64bit Unicode
Card name: NVIDIA GeForce RTX 2080 SUPER

Offline dink

  • Administrator
  • *****
  • Posts: 3907
  • Karma: +330/-0
  • pie? I nearly bought one!
Re: Opening FBNeo taking longer than 1 min
« Reply #1 on: January 05, 2021, 08:05:16 PM »
Try grabbing the debug version from our github repo https://github.com/finalburnneo/FBNeo-WIP-Storage-Facility/releases/download/appveyor-build/fbn-win32-debug-gcc.7z
Check Misc -> Options -> Show debug console (requires restart)
close and reload fbn
When it gets stuck loading: make a screen capture of the debug console window, then when it finishes loading make another and post them here, it might give a clue to what is going on.

best regards,
- dink

Offline kousoku

  • New Member
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Opening FBNeo taking longer than 1 min
« Reply #2 on: January 05, 2021, 11:32:08 PM »
Okay, so I enabled the debug console and restarted. When I restarted this comes up on the debug console:

https://imgur.com/a/e6uXdNC

After about 1 min, it loads the rest of what you see in this next screenshot and FBNeo opens:

https://imgur.com/a/QnPtboa
« Last Edit: January 05, 2021, 11:33:47 PM by kousoku »

Offline dink

  • Administrator
  • *****
  • Posts: 3907
  • Karma: +330/-0
  • pie? I nearly bought one!
Re: Opening FBNeo taking longer than 1 min
« Reply #3 on: January 05, 2021, 11:40:07 PM »
Can you try:
uncheck Misc -> Options -> Enable high resolution system timer

install or re-install dx 9 end user runtimes from here:
https://www.microsoft.com/en-us/download/details.aspx?id=8109

best regards,
- dink

Offline kousoku

  • New Member
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Opening FBNeo taking longer than 1 min
« Reply #4 on: January 05, 2021, 11:53:12 PM »
Unchecked the "Enable high resolution timer" and closed FBNeo. Selected your link and downloaded the dx 9 runtimes. Ran the DXSETUP.exe to install the runtimes. Reopened FBneo and still had the 1ish minute delay in opening the application.

On restart:
https://imgur.com/a/utImhN6
After 1.15 mins:
https://imgur.com/a/sMEd0VM


Offline dink

  • Administrator
  • *****
  • Posts: 3907
  • Karma: +330/-0
  • pie? I nearly bought one!
Re: Opening FBNeo taking longer than 1 min
« Reply #5 on: January 05, 2021, 11:57:28 PM »
Try setting blitter (Video -> Select Blitter) to: Experimental, how about then?

Offline kousoku

  • New Member
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Opening FBNeo taking longer than 1 min
« Reply #6 on: January 05, 2021, 11:58:06 PM »
UPDATE: Sorry for the double post.

After installing the dx 9 .exe I restarted my computer. This seems to have fixed the issue! It opened instantly! Thank you for your help.

Offline dink

  • Administrator
  • *****
  • Posts: 3907
  • Karma: +330/-0
  • pie? I nearly bought one!
Re: Opening FBNeo taking longer than 1 min
« Reply #7 on: January 06, 2021, 01:33:14 AM »
glad to hear :)