Author Topic: Mechanized Attack, player 1 controls not working  (Read 335 times)

Offline MetalGod

  • Newbies
  • *
  • Posts: 6
  • Karma: +0/-0
Mechanized Attack, player 1 controls not working
« on: February 14, 2019, 05:47:54 PM »
Hi !
I found a bug on fba last version.
Mechanized Attack controls for player 1 doesn't work, at least the movement axxis.

I'm using retropie :)
« Last Edit: February 14, 2019, 05:50:08 PM by MetalGod »

Offline dink

  • Administrator
  • *****
  • Posts: 2877
  • Karma: +245/-0
  • feed the horse yumyum
Re: Mechanized Attack, player 1 controls not working
« Reply #1 on: February 14, 2019, 06:40:03 PM »
I tried in FBAlpha and it works fine, I wonder if the problem is in the Retropie layer between FBAlpha and Retropie? 

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 360
  • Karma: +16/-1
  • lr-fbalpha developer
Re: Mechanized Attack, player 1 controls not working
« Reply #2 on: February 14, 2019, 11:36:00 PM »
Hi !
I found a bug on fba last version.
Mechanized Attack controls for player 1 doesn't work, at least the movement axxis.

I'm using retropie :)
They work, actually i fixed them 20 days ago in the libretro port, you just aren't using the last version.
Also, i would prefer you post issues specific to the libretro port on github : https://github.com/libretro/fbalpha/issues , or even better, the retropie forum for setup issue like this one.
« Last Edit: February 14, 2019, 11:40:30 PM by barbudreadmon »

Offline MetalGod

  • Newbies
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Mechanized Attack, player 1 controls not working
« Reply #3 on: February 15, 2019, 10:04:59 AM »
HI
I'm a noob in final burn alpha
The version I have is 0.2.97.43, which seems to be the official one. At least it is the available version here.
It seems I should download that libretro version, 0.44
Thank you.
« Last Edit: February 15, 2019, 10:09:11 AM by MetalGod »

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 360
  • Karma: +16/-1
  • lr-fbalpha developer
Re: Mechanized Attack, player 1 controls not working
« Reply #4 on: February 15, 2019, 10:10:19 AM »
It seems I should download that libreto version, 0.44
Most likely you used the pre-packaged binary version from retropie, which might be outdated. What you want is building it from sources (should be an option somewhere in the retropie setup script)

Offline MetalGod

  • Newbies
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Mechanized Attack, player 1 controls not working
« Reply #5 on: February 15, 2019, 02:54:37 PM »
I've updated my cores from sources (it was explicitaly indicated inside retropie setup). Now I have a new version of fba "FB Alpha 0.2.97.44 cfbe1e1" but nah, it still doesn't work.

Button 1, Button 2, Start and Coin and the only inputs Player 1 has. Gun X+, Gun X-, Gun Y+ and Gun Y- are still missing.

Offline MetalGod

  • Newbies
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Mechanized Attack, player 1 controls not working
« Reply #6 on: February 16, 2019, 09:51:27 AM »
Solved
I've updated from source only the fba package and it is solved. My version now is 0.2.97.44 00581bf3.

« Last Edit: February 16, 2019, 10:14:02 AM by MetalGod »

Offline MetalGod

  • Newbies
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Mechanized Attack, player 1 controls not working
« Reply #7 on: February 18, 2019, 05:53:03 PM »
Same problem in Steel Gunner 1 and 2.
I've opened this issue:  https://github.com/libretro/fbalpha/issues/146
but my account is flagged and this makes invisible every issue I open...
« Last Edit: February 18, 2019, 06:55:36 PM by MetalGod »

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 360
  • Karma: +16/-1
  • lr-fbalpha developer
Re: Mechanized Attack, player 1 controls not working
« Reply #8 on: February 19, 2019, 12:54:55 AM »
Fixed