Author Topic: bug sound pulstar neogeo  (Read 455 times)

Offline sniper856

  • Newbies
  • *
  • Posts: 10
  • Karma: +0/-0
bug sound pulstar neogeo
« on: May 25, 2019, 10:51:53 PM »
Hi guys, there is a bug of sound a little annoying in final burn (it does not exist on mame). It's at the end of the level when you beat the boss and you see your ship leaving. Normally we must hear the sound of the score counter. With mame it works very well but with final burn the sound of the score counter is missing.
I can make a video to show you  if you want. Is it possible to easily fix this?

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 411
  • Karma: +17/-1
  • lr-fbalpha developer
Re: bug sound pulstar neogeo
« Reply #1 on: May 26, 2019, 05:20:30 AM »
Thanks for reporting this, are you using standard settings ? If you are using specific settings for bios or overclocking, it's important to tell us.
Giving us a savestate prior to beating the boss would be perfect !

Offline dink

  • Administrator
  • *****
  • Posts: 3042
  • Karma: +259/-0
  • feed the horse yumyum
Re: bug sound pulstar neogeo
« Reply #2 on: May 26, 2019, 08:10:16 AM »
I'm going to fix this as soon as I get done with my current project (gng rewrite) :)

best regards,
- dink

Offline dink

  • Administrator
  • *****
  • Posts: 3042
  • Karma: +259/-0
  • feed the horse yumyum
Re: bug sound pulstar neogeo
« Reply #3 on: May 26, 2019, 09:09:46 AM »
sniper856, thanks for the bug report, should be fixed now :)

barbudreadmon, can you believe - it was the speedhack again :P  I think I got a good value in there which should be compatible with all of the "problematic" games, but, it does need testing.

best regards,
- dink

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 411
  • Karma: +17/-1
  • lr-fbalpha developer
Re: bug sound pulstar neogeo
« Reply #4 on: May 26, 2019, 09:28:06 AM »
barbudreadmon, can you believe - it was the speedhack again :P
I had a guess, that's why i asked for bios and overclock settings, i remember all the odd cases where it would only happen with unibios set to USA, or with overclocking.

Offline dink

  • Administrator
  • *****
  • Posts: 3042
  • Karma: +259/-0
  • feed the horse yumyum
Re: bug sound pulstar neogeo
« Reply #5 on: May 26, 2019, 09:58:00 AM »
do you remember which game it was that had issues with alternate bios's and the speedhack?  I can't remember :(  I'd like to test it with the new code.

best regards,
- dink

Offline barbudreadmon

  • Administrator
  • *****
  • Posts: 411
  • Karma: +17/-1
  • lr-fbalpha developer
Re: bug sound pulstar neogeo
« Reply #6 on: May 26, 2019, 10:09:23 AM »
I think that's the full list of known problematic games :
gpilots
nam1975
bstars
karnovr
aof3
s1945p

Offline sniper856

  • Newbies
  • *
  • Posts: 10
  • Karma: +0/-0
Re: bug sound pulstar neogeo
« Reply #7 on: May 26, 2019, 03:19:28 PM »
I had a guess, that's why i asked for bios and overclock settings, i remember all the odd cases where it would only happen with unibios set to USA, or with overclocking.

hello thank you for your answer, no I did not use overclocking and the bios was in MVS ASIA EUR memory. This is an old problem that I mentioned several years ago. Thank you guys for taking care of it, you are great.

Offline sniper856

  • Newbies
  • *
  • Posts: 10
  • Karma: +0/-0
Re: bug sound pulstar neogeo
« Reply #8 on: May 26, 2019, 03:42:54 PM »
sniper856, thanks for the bug report, should be fixed now :)

barbudreadmon, can you believe - it was the speedhack again :P  I think I got a good value in there which should be compatible with all of the "problematic" games, but, it does need testing.

best regards,
- dink

Thank you, I will wait for a libretro update or the new FBNEO to be able to test and report to you  ;p

EDIT 30/05/2019 : the bug is fixed, thanks
« Last Edit: May 30, 2019, 04:05:37 PM by sniper856 »