Author Topic: dink's FBA Development & Fixes thread  (Read 223049 times)

Offline dink

  • Administrator
  • *****
  • Posts: 2874
  • Karma: +244/-0
  • feed the horse yumyum
Re: dink's FBA Development & Fixes thread
« Reply #1620 on: May 12, 2019, 07:41:25 PM »
DarkShadowMD,
That's good to know :)  thanks

best regards,
- dink

Offline dink

  • Administrator
  • *****
  • Posts: 2874
  • Karma: +244/-0
  • feed the horse yumyum
Re: dink's FBA Development & Fixes thread
« Reply #1621 on: May 12, 2019, 08:01:28 PM »
dink vs.  Ryvius86: Game Selector Filter fun
The idea arose sometime yesterday - wouldn't it be great if the expanded state of the filter tree were saved?

For example: let's say you only use the "Genre" section of the Filters - you would want that section to be open every time you went to the game list, right?

Consider it done! :)

best regards,
- dink
« Last Edit: May 12, 2019, 08:02:30 PM by dink »

Offline DarkShadowMD

  • Newbies
  • *
  • Posts: 13
  • Karma: +0/-0
  • I like arcades and art!
    • DarkShadow M.D. Art Corner
Re: dink's FBA Development & Fixes thread
« Reply #1622 on: May 16, 2019, 10:30:48 PM »
Hey there!

I'm here bugging again!

Well, for some reason, I'm able to reproduce the bug I mentioned about Kof2003 PCB in the latest 2.97.44 build (or at least the latest build I have):
- Load the game (no fs file or ini file present)
- Sound works
- Press F2 to load game settings
- Text is garbled and corrupted (I'm attaching image)
- Reset with F3
- No sound is heard now.

If you close the game and launch again, you also get no sound until you erase the kf2k3pcb.fs file. I haven't tested if launching, closing and not trying to enter the BIOS settings renders the sound muted.

EDIT: I tested launching the game, not touching anything, closing and then relaunching, same no sound bug as the former description. You only get sound back when you delete the fs file prior to loading the game.

I'm attaching the files you requested since last time.

Cheers!
« Last Edit: May 16, 2019, 10:37:07 PM by DarkShadowMD »
No.... no no no... it's not Sarcoidosis!

Offline dink

  • Administrator
  • *****
  • Posts: 2874
  • Karma: +244/-0
  • feed the horse yumyum
Re: dink's FBA Development & Fixes thread
« Reply #1623 on: May 17, 2019, 09:16:31 AM »
DarkShadowMD, thanks for the info!
I'll try to figure it out.  First attempt was unsuccessfull :(

best regards,
- dink

Offline dink

  • Administrator
  • *****
  • Posts: 2874
  • Karma: +244/-0
  • feed the horse yumyum
Re: dink's FBA Development & Fixes thread
« Reply #1624 on: Today at 09:56:22 AM »
Newy newness:
superctr ported his super-accurate QSound HLE engine to FB, games using QSound really sound great now :)
Adds delay/filtering effects that the original chip had to give it super nice stereo effects.

CupcakeFan re-wrote the galaga/digdug driver, adding the excellent classic Xevious

A few days back superctr posted a change that fixed an issue with parallel make.  I found another issue when compiling cleanly and patched that as well.  Now fb can be compiled super-fast with make -jXX in 1 pass, instead of several.

How to build FinalBurn Neo super-fast with MingW/gcc?
edit makefile.mingw, find this like:  (note: don't change to DEPEND = 0)
DEPEND = 1
change it to:
#DEPEND = 1

from MingW/gcc 6.3 or 8.x shell in the fbneo source tree, run:
make -j20 mingw510

All attached is a new exe for your enjoyment/testing/etc :)

best regards,
- dink
« Last Edit: Today at 10:07:32 AM by dink »

Offline DarkShadowMD

  • Newbies
  • *
  • Posts: 13
  • Karma: +0/-0
  • I like arcades and art!
    • DarkShadow M.D. Art Corner
Re: dink's FBA Development & Fixes thread
« Reply #1625 on: Today at 04:48:40 PM »
Thank you so much for this hard work!

Oh, I noticed the about menu still says "About FB Alpha", just in case you missed it :P

I can't wait to test some games on it!

Cheers!

EDIT: I tested kf2k3pcb again, the sound problem when resetting is gone, but the BIOS settings still look like corrupted for some reason... I tested on MAME (how sluggish that thing is even in my system with 16 GB... geez!) and you can see the BIOS... in japanese and you understand nothing, but at least you can see it and configure what you kind of know it's the difficulty and other stuff...
« Last Edit: Today at 05:35:29 PM by DarkShadowMD »
No.... no no no... it's not Sarcoidosis!

Offline dink

  • Administrator
  • *****
  • Posts: 2874
  • Karma: +244/-0
  • feed the horse yumyum
Re: dink's FBA Development & Fixes thread
« Reply #1626 on: Today at 07:05:50 PM »
DarkShadowMD, thanks :)
We have a lot of changes to make yet, regarding FBAlpha -> FB Neo.   Also, the kf2k3pcb bios issue is a tough one, please bear with us for now :)

best regards,
- dink

Offline DarkShadowMD

  • Newbies
  • *
  • Posts: 13
  • Karma: +0/-0
  • I like arcades and art!
    • DarkShadow M.D. Art Corner
Re: dink's FBA Development & Fixes thread
« Reply #1627 on: Today at 07:12:43 PM »
No problem man, you are already doing a magnificent job with the emu and the team. I know this takes some time! (while you were rather quick to address stuff tbh)

Take your time, I just report this bug for you to know, but yo do you!

Thank you so much!
No.... no no no... it's not Sarcoidosis!